Skip to main content
                     
As-Built As-Built - Revit As-Built - AutoCAD VirtuSurv - VirtuSurv 2018 As-Built - Modeler VirtuSurv - VirtuSurv 2019          
BuildIT BuildIT - Projector BuildIT - Construction BuildIT - Metrology              
CAM2 CAM2 - SmartInspect CAM2 - 2018 CAM2 - Measure 10 CAM2 - Measure Q CAM2 - Measure X CAM2 - Measure 3/4 CAM2 - AnthroCAM CAM2 - 2019    
Cobalt 3D Imager 3D Imager - Cobalt                  
Computers Computers - All Computers                  
FARO Aras 360 & CAD Zone FARO CAD Zone - Fire & Insurance FARO CAD Zone - Crime & Crash FARO CAD Zone - CZ Point Cloud FARO CAD Zone - First Look Pro FARO 360 - Reality FARO 360 - HD FARO 360 - Blitz FARO 360 - Genius    
FARO Zone present4D - present4D                  
FARO Zone 2D FARO Zone 2D - 2018 FARO Zone 2D - 2019                
FARO Zone 3D FARO Zone 3D - 2018 FARO Zone 3D - 2019                
FARO Zone 3D Advanced FARO Zone 3D Advanced - 2018 FARO Zone 3D Advanced - 2019                
FaroArm/ScanArm FaroArm/ScanArm - Quantum S FaroArm/ScanArm - Quantum M FaroArm/ScanArm - Quantum E FaroArm/ScanArm - Edge FaroArm/ScanArm - Fusion FaroArm/ScanArm - Prime FaroArm/ScanArm - Platinum FaroArm/ScanArm - Legacy Quantum FaroArm/ScanArm - Titanium FaroArm/ScanArm - Advantage
FaroArm/ScanArm FaroArm/ScanArm - Digital Template                  
Gage Gage - Bluetooth Gage - Plus Gage - Standard Gage - Power            
Hand Held Scanner 2D Hand Held Scanner - ScanPlan 3D Hand Held Scanner - Freestyle3D 3D Hand Held Scanner - Freestyle3D X 3D Hand Held Scanner - Freestyle3D Objects            
Language Quality HT MT AT NT INT - Internal          
Languages Language - English Language - Japanese Language - German Language - Chinese Language - Spanish Language - Italian Language - Portuguese Language - French    
Laser Projector RayTracer - RayTracer Laser Projector - Tracer M Laser Projector - Tracer SI              
Laser Radar Imaging Laser Radar - VectorRI                  
Laser Scanner 3D Laser Scanner - Focus S 3D Laser Scanner - Focus M 3D Laser Scanner - Focus3D 3D Laser Scanner - Focus3D X 3D Laser Scanner - Focus3D X HDR 3D Laser Scanner - Focus3D S 3D Laser Scanner - Photon      
Laser Tracker Laser Tracker - Vantage Laser Tracker - ION Laser Tracker - Vantage S Laser Tracker - Si Laser Tracker - X Laser Tracker - Xi Laser Tracker - Vantage E Laser Tracker - Vantage S6 Laser Tracker - Vantage E6  
Legacy Software Legacy Software - CAM2 Gage Legacy Software - Gage Software Legacy Software - Insight              
Open Tech Dental Open Technologies Scanner - NeWay Open Technologies Scanner - Click Open Technologies Scanner - Deluxe Open Technologies Scanner - Smart Open Technologies Scanner - Easy Open Technologies Software - 1Click Open Technologies Software - Optical RevEng Dental Open Technologies Software - ScanWay    
Photonics Scan Head - Digi-Cube Scan Head - Xtreme Scan Head - 3D-Contour Scan Head - 3D-Ultralight Scan Head - 3D-XB Controller - LEC Series Controller - Maestro 3000 Nutfield - Nutfield Hardware Nutfield - Nutfield Software Scan Head - Blink Focuser
Photonics WinLase - Pro WinLase - LAN WinLase - 6              
PointSense PointSense - Basic PointSense - Pro PointSense - Building PointSense - Plant PointSense - Heritage PointSense - Revit CAD Plugin - TachyCAD Building CAD Plugin - TachyCAD Archeology CAD Plugin - TachyCAD Interior CAD Plugin - PhoToPlan Basic
PointSense CAD Plugin - PhoToPlan CAD Plugin - PhoToPlan Pro CAD Plugin - PhoToPlan Ultimate CAD Plugin - DisToPlan CAD Plugin - MonuMap CAD Plugin - hylasFM CAD Plugin - VirtuSurv      
RevEng RevEng - RevEng                  
Scan in a Box Scan in a Box - M Scan in a Box - S                
ScanArm ScanArm - Design ScanArm 2.0 ScanArm - Design ScanArm ScanArm - Forensic ScanArm ScanArm - Design ScanArm 2.5C            
SCENE SCENE - Capture and Process SCENE - WebShare Server and 2Go SCENE - WebShare Cloud SCENE - WebShare 2Go App SCENE - 2018 SCENE - 7.x SCENE - 6.x SCENE - 5.x SCENE - 4.x SCENE - LT
SCENE SCENE - 2019 SCENE - 2go App                
Serial FaroArm Serial FaroArm - Silver Serial FaroArm - Gold Serial FaroArm - Bronze              
Structured Light Scanners Cobalt Design - M Cobalt Design - S Cobalt Design - Dual              
Visual Inspect Visual Inspect - App Visual Inspect - CAD Translator                
FARO® Knowledge Base

Activate or Update a SCENE License Product Key or Dongle

FARO SCENE Screen and Box

Before You Begin

  1. Make sure you have a stable internet connection.
  2. Ensure you have administrator privileges on your PC.
  3. Turn off all anti-virus and firewall software. If you do not know how to do this, contact your IT department.
  4. If you use a dongle, insert it into the computer's USB port before you proceed.
    Caution: If you do not insert the dongle, the software will not find a license key and the activate or update process fails. To correct this, close FARO® SCENE, insert the dongle, and start again.

Overview

When you purchase SCENE you will receive a license key either as a dongle/portlock or product key you type into the software. The key entitles you to receive software upgrades during a specified time. 

Activating a Key

  • Dongle/Portlock Before you open SCENE, insert the dongle into a USB port on your computer. The license will be automatically detected when you run SCENE. 
  • Product Key - You must activate a product key the first time you run SCENE. If you are using SCENE 2019.1 or later, you will see the license activation wizard. Click here for more information about using the wizard. Otherwise, you can activate your key using the License Manager.
  • Trial Key - SCENE comes with a 30-day trial license key for pre-purchase evaluation. The trial key does not have to be activated.

Updating a Key

If you have activated the Automatically check for software updates setting, you will be notified when a new version of SCENE is available when you run the program.  Note: You can activate this setting in the Settings > General menu by checking the Automatically check for software updates box.     

When you upgrade, the process is automatic as long as your warranty is up-to-date. You can check you warranty status on FARONOW. If your warranty is expired, you can still use your current version of SCENE. But, you will not be able to run software upgrades on an ongoing basis until you renew the warranty. Click here for information about how to renew your warranty. 

After you renew the warranty, use the manual product key update to apply the update and extend the time on your existing key: either dongle or product key. 

Note: When you upgrade SCENE from one major release to another, the software may still prompt you to update your key even with an up-to-date warranty. When this happens, just update the key without concern about the warranty.   

Tips

  • Make your life easier by keeping a list of keys, related installations of SCENE on specific computers in your work environment, and related warranty IDs. This list helps you when it is time to renew warranties.
  • Start with the automatic process first and use manual processes only if necessary.
  • Check below for instructions for key activation for older versions of SCENE and the different SCENE interfaces. 
  • If you use network license keys, click here for instructions.

License Manager

To help you maintain keys, SCENE has a built-in License Manager. It enables you to add, activate, manage, update, and transfer keys, as well as check information such as license type and expiration date. 

Back to top

SCENE 2019.1 or Later Versions

Access the License Manager

  1. Click on the Gear SCENESettingsIcon.png icon in the top-right corner, then on the ribbon click License Manager. The License Manager appears. 
  2. If all of the license options are not visible, click the More Options button on the bottom of the License Manager window.
  3. Select the license option.

Start Trial

Use this option to start a 30-day trial of the SCENE software.

Add License

  1. In the License Manager, click Add License
  2. Enter your product key in the Product Key field and click Submit.
     
  3. A message appears indicating the license activated successfully. Click OK
  4. If license key messages continue to appear, use the manual activate process in the section below.  

Update Licenses

Use this if you have an existing license, but it did not update automatically. If error messages continue to appear, use the manual update process below.

Transfer Key

If you get a new computer or hard drive, you can transfer the key from the old computer to the new one. Note: Transferring a key removes it from the source computer. 

The instructions below assume SCENE is installed and licensed on the source PC, and the recipient PC has a version of SCENE with a valid trial license. If the trial license has expired, you will need to contact FARO Support.

Transferring a Key Over a Network
  1. On the recipient PC, open SCENE and access the License Manager. Click Transfer key.
  2. Select the source PC from the list of network hosts.
  3. Click Transfer.
On Source Computer, Check License
  1. On the source computer, using a browser go to http://localhost:1947/_int_/devices.html.
    SentinalLicenseKeys.PNG
  2. On the Sentinel Admin Control Center page, each row contains information about a specific product key that is available on that computer. You can only transfer product keys that are Local and have TransferLicenseIcon.png in the Configuration column. If the license you want to transfer does not meet these conditions, contact FARO Support.
Create .id File on Recipient PC
  1. On the recipient PC, open SCENE and access the License Manager. Click Transfer key.
  2. Click Transfer with RUS tool.
  3. In the RUS window, click the Transfer License tab.
     
  4. In the Collect information about the recipient computer area, click TransferLicenseBrowseIcon.PNG and navigate to a location where you can store the recipient computer's .id file.
  5. Click Save
  6. Click Collect and Save Information. A message appears telling you the file was saved in the chosen location. Click OK. Leave the RUS tool open.   
  7. Copy the recipient computer's .id file to the source computer. 
On Source Computer, Create a .h2h File
  1. On the source computer, open SCENE and access the License Manager. Click Transfer key.
  2. Click Transfer with RUS tool.
  3. Close SCENE, keeping the RUS window open.
    You must close SCENE because in the next steps, the product key will be removed and you will no longer be able to use SCENE on the source computer. 
  4. In the RUS window, in the Generate the license transfer file area, click on the row for the product key you want to transfer. 
  5. In the Read the recipient information file from field, click TransferLicenseBrowseIcon.PNG and navigate to location where you copied the recipient computer's .id file. Click Open. The .id file location appears in the field
  6. In the Generate the license transfer file to field, click TransferLicenseBrowseIcon.PNG and navigate to a location where you want to store the transfer file.h2h. Click Save and close the RUS tool.
  7. Copy the transfer file.h2h, to the recipient computer. 
On Recipient Computer, Apply a .h2h File
  1. On the recipient computer, in the RUS window, click the Apply License File tab.
  2. In the Update File field, click TransferLicenseBrowseIcon.PNG and navigate to a location where you copied the transfer file.h2h. Click Open. The .h2h file location appears in the field
  3. Click Apply Update. Details about the transferred license appear in the Apply License File tab, indicating the transfer process was successful.
  4. You may close the RUS tool and use SCENE on the recipient computer.   

Collect License Information

Use this option to generate a .C2V file. This file is unique to your computer and is used to manually activate a license.

Update From File

When you manually update a license, FARO Support will email you a .V2C file. Use this option to navigate to the .V2C file and update your license.

Manually Activate a License

To manually activate a product key, you will need to create a .C2V file, send it to FARO support, and manually activate your software with the file the support team sends back.

Create a .C2V File

  1. Click on the Gear SCENESettingsIcon.png icon in the top-right corner, then on the ribbon click License Manager. The License Manager appears. 
  2. If all of the license options are not visible, click the More Options button on the bottom of the License Manager window.
  3. Select the Collect license information option.
  4. Email the file to SCENE-Licensing@faroeurope.com with the subject SCENE - Activation file request.ActivationEmail.PNG
    Within one day or less, you should receive an email with an attached .V2C file from the FARO automated license system. 

Activating a License Wtih a .V2C File

  1. After receiving the .V2C file, save it to the SCENE PC.
  2. Open the License Manager and select Update from file.
  3. Navigate to and select the .V2C file.
  4. Click Open.

 

Workflow Interface

Access the License Manager

  1. Click on the Gear SCENESettingsIcon.png icon in the top-right corner, then on the ribbon click License Manager. The License Manager appears. 

Automatically Activate a Product Key

  1. In the License Manager, click Add Product Key
  2. In the Product Activation window, on the Automatic Activation tab, enter your product key in the Product Key field and click Activate.
     ProductActivationWindow.PNG
  3. A message appears indicating the license activated successfully. Click OK here and on the next window. 
  4. In the Workspace window, on the top ribbon, in the top-left corner, click the Back Arrow BackArrowIcon.PNG icon. The Project Overview page appears.
  5. Your license is activated and you can use SCENE.
    If license key messages continue to appear, use the manual activate process in the section below.
    InitialSCENEOpenPage.PNG  

Automatically Update an Existing Key

If you have just downloaded and installed a SCENE upgrade and have an up-to-date warranty, follow these instructions. To be sure your warranty is up to date, check its status on FARONOW. If your warranty is not up-to-date, click here to purchase an extension, then go to the manual product key update section in this article to apply the update and extend the time on your existing key.

If you are using a dongle, before you begin, insert the dongle into a USB port on your computer.

  1. On your desktop, double-click the new SCENE Software SCENE7ShortCut.PNG icon to run the software. Either the software runs correctly or you may see a license error message.
    • If the software runs, you are done!
    • If a license error message appears, click Yes, and the License Manager appears. If the License Manager does not appear, use the steps above to access the License Manager.
      UpdateLicense.png
       
  2. In the License Manager, click Update Licenses
  3. Follow the prompts until the process completes. Your license is automatically updated so you can use SCENE.
    If error messages continue to appear, use the manual update process in the section below.
Back to top

Classic Interface

Access the License Manager

  1. On the computer desktop, double-click the SCENE SCENE7ShortCut.PNG icon. SCENE opens in the workflow interface.
  2. Click on the Gear SCENESettingsIcon.png icon in the top-right corner, then on the ribbon click Switch User Interface. The classic interface appears.
  3. On the menu bar, click Help > Licensing. The License Manager appears.  

Automatically Activate a Product Key

  1. In the License Manager, click Add Product Key
  2. In the Product Activation window, on the Automatic Activation tab, enter your product key in the Product Key field and click Activate.
     ProductActivationWindow.PNG
  3. A message appears indicating the license activated successfully. Click OK here on the next window. 
  4. Your license is activated. If license key messages continue to appear, use the manual activate process in the section below.

Automatically Update an Existing Key

If you have just downloaded and installed a SCENE upgrade and have an up-to-date warranty, follow these instructions. To be sure your warranty is up to date, check its status on FARONOW. If your warranty is not up-to-date, click here to purchase an extension, then go to the manual product key update section in this article to apply the update and extend the time on your existing key.

If you are using a dongle, before you begin, insert the dongle into a USB port on your computer.

  1. Open SCENE. Either the software runs correctly, or you may see a license error message.
    • If the software runs, you are done!
    • If a license error message appears, click OK, and the License Manager appears. If the License Manager does not appear, use the steps above to access the License Manager.
      SCENE License Error 35858
  2. In the License Manager, click Update Licenses. An informational message appears reminding you that you must have a valid warranty. Click Yes to continue.
    Scene License Message to Proceed
  3. The key update process runs. Do not close this window. It may take several minutes.
    SCENE License Manager Progress Bar
  4. When the Successfully updated licenses message appears, click OK. Your license is automatically updated and activated.
    If error messages continue to appear, use the manual update process in the section below..
    SCENE License Manager Successful Message
Back to top

SCENE 5.5 or Earlier

Access the License Manager

  1. Open SCENE. A license error message appears.
    LicenseError35873.PNG
  2. Click OK.The License Manager window appears. If the License Manager does not appear, on the menu bar, go to Help > Licensing.

Automatically Activate a Product Key

  1. In the License Manager, click Add Product Key
  2. In the Product Activation window, on the Automatic Activation tab, enter your product key in the Product Key field and click Activate.
     ProductActivationWindow.PNG
  3. Your license is activated.
    If license key messages continue to appear, use the manual activate process in the section below.

Automatically Update an Existing Key

If you have just downloaded and installed a SCENE upgrade and have an up-to-date warranty, follow these instructions. To be sure your warranty is up to date, check its status on FARONOW. If your warranty is not up-to-date, click here to purchase an extension, then go to the manual product key update section in this article to apply the update and extend the time on your existing key.

If you are using a dongle, before you begin, insert the dongle into a USB port on your computer.

  1. In the License Manager, click Update Licenses
  2. Follow the prompts until the process completes. Your license is automatically updated.
    If error messages continue to appear, use the manual update process in the section below.
Back to top

Manually Activate a Product Key

To manually activate a product key, you will create and email an .AR file to the FARO automated license system. The system will respond with a .V2C file, which is needed to activate your license.

.AR and .V2C files are unique to your computer and hold information pertaining to FARO software product keys. Note: You cannot interchange these files with different computers.

  1. On the computer where you want to activate the license, open SCENE and access the License Manager.
  2. In the License Manager window, click Add Product Key
  3. In the Product Activation window, click the Manual Activation tab.
  4. In the Product Key field, type the product key and click Send. An email appears addressed to SCENE-Licensing@faroeurope.com. Send the email.
    Within one day or less, you should receive an email with an attached .V2C file from the FARO automated license system. Drag the file from the email to a file storage location on the computer. 
    ActivationEmail.PNG
  5. In the Product Activation window, on the Manual Activation tab, in the Process Activation File area, click TransferLicenseBrowseIcon.PNG and navigate to a location where you stored the .V2C file. Click Open. The .V2C file location appears in the field. 
  6. Click Activate
    When the process is complete, a success message appears.
  7. Open SCENE. 
    If license messages continue to appear, contact FARO Support.
Back to top

Manually Update an Existing Key/Create .C2V File

To manually update an existing key, you will create a .C2V file and send it to the FARO automated license system. The system will send you an email with a matching .V2C file attached. Applying this file updates the license keys stored on your computer or dongle.

.C2V and .V2C files are unique to the computer you use with SCENE and hold information pertaining to FARO software product keys. Note: You cannot interchange these files with different computers.

To create a .C2V file, use the FARO Remote Update System (RUS) tool. Before you begin, make sure you already have entered the product keys you have or, if you are using a dongle, make sure it is properly connected to your computer's USB port.

If you are using a dongle, before you begin, insert the dongle into a USB port on your computer.

Create a .C2V File

  1. On the computer where you want to update the license key, open the RUS. From the Start menu, click All Programs > FARO > SCENE FaroRUS. The RUS window appears.
    RUSCollectTab.PNG
  2. On the Collect Status Information tab, select Update of existing protection key, and click Collect Information. The Select Sentinel Protection Key dialog box appears.
    • If you only use one product key or dongle on this computer, click OK and continue to the next step.
    • If you use multiple product keys or dongles on this computer, for FARO or any other vendor's software, select the product/license key that applies to your FARO software and click OK.
    Note: Under Key TypeHL- stands for hard lock--a license key stored on a dongle
                                          SL- stands for soft lock--a product key stored in the software on your computer.
    RUSSCENELicenses.PNG    RUSMultipleLicenses.png
  3. In the Save Key Status As window, navigate to the location where you want to save the .C2V file, enter a File name, and click Save.
  4. The RUS dialog box appears with a success message when the process is complete.
    RUSSuccessMessage.PNG
  5. Locate the .C2V file, attach it to an email, and send it to scene-licensing@faroeurope.com.
    Within several minutes, this automated system sends you an email reply with an attached .V2C file. If you do not receive the .V2C file from the automated system within half an hour, contact FARO Support.

Apply a .V2C File 

Once you receive the automated email with the .V2C file, use the FARO Remote Update System (RUS) to apply the file. If you use a dongle, make sure it is properly connected to your computer's USB port before you begin.

  1. On the computer where you want to update the license key, save the .V2C file attached to the email you received from the FARO automated license update system. If you have not received this email, contact FARO Support.
  2. From the Start menu, click All Programs FARO SCENE FaroRUS. The RUS window appears.
  3. Click the Apply License Update tab and click BrowseButton.PNG to navigate to the location where you saved the .V2C file.
    FARO-RUS.PNG
  4. In the Select the file to apply window, click All Files (*.*), select the .V2C file, and click Open.
    FaroRUS-SelectTheFileToApplyWindow.png
  5. Click Apply Update.
  6. The RUS window appears with a success message when the process is complete.
  7. Open SCENE. 
    If the license error messages continue to appear, please contact FARO Support.
Back to top

Transfer a Product Key from One Computer to Another

The Transfer Product Key feature is available for SCENE 7.0 and later. If you are using an earlier version of SCENE, contact FARO Support to transfer the product key. 

If you get a new computer or hard drive and you use a product key (a key you type into the SCENE software), you can rehost or transfer the key from the old computer to the new one, or from an old hard drive to a new one. When you transfer the key, it is removed from the old computer or hard drive (the source computer) and moved to the new computer or hard drive (the recipient computer). The product key transfer processes uses the FARO Remote Update System (RUS) tool on both the source and recipient computer.

The instructions below assumes that SCENE has been installed and licensed on the source computer, and that SCENE is installed on the recipient computer using a trial license that has not yet expired. If the trial license has expired, you will not be able to complete these instructions successfully. Contact FARO Support.

On Source Computer, Check License is Transferable

  1. On the source computer, using a browser go to http://localhost:1947/_int_/devices.html.
    SentinalLicenseKeys.PNG
  2. On the Sentinel Admin Control Center page, each row contains information about a specific product key that is available on that computer. You can only transfer product keys that are Local and have TransferLicenseIcon.png in the Configuration column. If the license you want to transfer does not meet these conditions, contact FARO Support.

On Recipient Computer, Create a .id File

  1. On the recipient computer, open SCENE and access the License Manager. Click Transfer License.
  2. The RUS window appears. Click the Transfer License tab. 
    RUSTransferLIcenseTab.PNG 
  3. In the Collect information about the recipient computer area, click TransferLicenseBrowseIcon.PNG and navigate to a location where you can store the recipient computer's .id file. Click Save
  4. Click Collect and Save Information. A message appears telling you the file was saved in the chosen location. Click OK. Leave the RUS tool open.   
  5. Copy the recipient computer's .id file to the source computer. 

On Source Computer, Create a .h2h File

  1. On the source computer, open SCENE and access the License Manager. Click Transfer License. The FARO Remote Update System (RUS) window appears. In the RUS window, click Transfer License.
  2. Close SCENE, keeping the RUS window open.
    You must close SCENE because in the next steps, the product key will be removed and you will no longer be able to use SCENE on the source computer. 
  3. In RUS window, in the Generate the license transfer file area, click on the row for the product key you want to transfer. 
  4. In the Read the recipient information file from field, click TransferLicenseBrowseIcon.PNG and navigate to location where you copied the recipient computer's .id file. Click Open. The .id file location appears in the field
  5. In the Generate the license transfer file to field, click TransferLicenseBrowseIcon.PNG and navigate to a location where you want to store the transfer file.h2h. Click Save and close the RUS tool.
  6. Copy the transfer file.h2h, to the recipient computer. 

On Recipient Computer, Apply a .h2h File

  1. On the recipient computer, in the RUS window, click the Apply License File tab.
    FARO-RUS.PNG
  2. In the Update File field, click TransferLicenseBrowseIcon.PNG and navigate to a location where you copied the transfer file.h2h. Click Open. The .h2h file location appears in the field
  3. Click Apply Update. Details about the transferred license appear in the Apply License File tab, indicating the transfer process was successful.
    RUSApplyLicenseFileTab2.PNG
  4. You may close the RUS tool and use SCENE on the recipient computer.   

See Also

Keywords

portlock, HASP, HL, upgrade, product key, license key, software key, hard lock, hardlock, HL lock, soft lock, softlock, software lock, SL lock, port lock, thumb drive, USB drive, flash drive, generate a c2v file, product key activation, license activation, offline license activation, offline product key activation, activate product key, transfer license, transfer product key, transfer license key, dongle not detected, license not detected, service plan, service agreement maintenance plan, maintenance agreement, support plan, support agreement, authorization, guarantee