Skip to main content
                     
As-Built As-Built - Revit As-Built - AutoCAD VirtuSurv - VirtuSurv 2018 As-Built - Modeler VirtuSurv - VirtuSurv 2019          
BuildIT BuildIT - Projector BuildIT - Construction BuildIT - Metrology              
CAM2 CAM2 - SmartInspect CAM2 - 2018 CAM2 - Measure 10 CAM2 - Measure Q CAM2 - Measure X CAM2 - Measure 3/4 CAM2 - AnthroCAM CAM2 - 2019    
Cobalt 3D Imager 3D Imager - Cobalt                  
Computers Computers - All Computers                  
FARO Aras 360 & CAD Zone FARO CAD Zone - Fire & Insurance FARO CAD Zone - Crime & Crash FARO CAD Zone - CZ Point Cloud FARO CAD Zone - First Look Pro FARO 360 - Reality FARO 360 - HD FARO 360 - Blitz FARO 360 - Genius    
FARO Zone present4D - present4D                  
FARO Zone 2D FARO Zone 2D - 2018 FARO Zone 2D - 2019                
FARO Zone 3D FARO Zone 3D - 2018 FARO Zone 3D - 2019                
FaroArm/ScanArm FaroArm/ScanArm - Quantum S FaroArm/ScanArm - Quantum M FaroArm/ScanArm - Quantum E FaroArm/ScanArm - Edge FaroArm/ScanArm - Fusion FaroArm/ScanArm - Prime FaroArm/ScanArm - Platinum FaroArm/ScanArm - Legacy Quantum FaroArm/ScanArm - Titanium FaroArm/ScanArm - Advantage
FaroArm/ScanArm FaroArm/ScanArm - Digital Template                  
Gage Gage - Bluetooth Gage - Plus Gage - Standard Gage - Power            
Hand Held Scanner 2D Hand Held Scanner - ScanPlan 3D Hand Held Scanner - Freestyle3D 3D Hand Held Scanner - Freestyle3D X 3D Hand Held Scanner - Freestyle3D Objects            
Language Quality HT MT AT NT INT - Internal          
Languages Language - English Language - Japanese Language - German Language - Chinese Language - Spanish Language - Italian Language - Portuguese Language - French    
Laser Projector RayTracer - RayTracer Laser Projector - Tracer M Laser Projector - Tracer SI              
Laser Radar Imaging Laser Radar - VectorRI                  
Laser Scanner 3D Laser Scanner - Focus S 3D Laser Scanner - Focus M 3D Laser Scanner - Focus3D 3D Laser Scanner - Focus3D X 3D Laser Scanner - Focus3D X HDR 3D Laser Scanner - Focus3D S 3D Laser Scanner - Photon      
Laser Tracker Laser Tracker - Vantage Laser Tracker - ION Laser Tracker - Vantage S Laser Tracker - Si Laser Tracker - X Laser Tracker - Xi Laser Tracker - Vantage E Laser Tracker - Vantage S6 Laser Tracker - Vantage E6  
Legacy Software Legacy Software - CAM2 Gage Legacy Software - Gage Software Legacy Software - Insight              
Open Tech Dental Open Technologies Scanner - NeWay Open Technologies Scanner - Click Open Technologies Scanner - Deluxe Open Technologies Scanner - Smart Open Technologies Scanner - Easy Open Technologies Software - 1Click Open Technologies Software - Optical RevEng Dental Open Technologies Software - ScanWay    
Photonics Scan Head - Digi-Cube Scan Head - Xtreme Scan Head - 3D-Contour Scan Head - 3D-Ultralight Scan Head - 3D-XB Controller - LEC Series Controller - Maestro 3000 Nutfield - Nutfield Hardware Nutfield - Nutfield Software Scan Head - Blink Focuser
Photonics WinLase - Pro WinLase - LAN WinLase - 6              
PointSense PointSense - Basic PointSense - Pro PointSense - Building PointSense - Plant PointSense - Heritage PointSense - Revit CAD Plugin - TachyCAD Building CAD Plugin - TachyCAD Archeology CAD Plugin - TachyCAD Interior CAD Plugin - PhoToPlan Basic
PointSense CAD Plugin - PhoToPlan CAD Plugin - PhoToPlan Pro CAD Plugin - PhoToPlan Ultimate CAD Plugin - DisToPlan CAD Plugin - MonuMap CAD Plugin - hylasFM CAD Plugin - VirtuSurv      
RevEng RevEng - RevEng                  
Scan in a Box Scan in a Box - M Scan in a Box - S                
ScanArm ScanArm - Design ScanArm 2.0 ScanArm - Design ScanArm ScanArm - Forensic ScanArm ScanArm - Design ScanArm 2.5C            
SCENE SCENE - Capture and Process SCENE - WebShare Server and 2Go SCENE - WebShare Cloud SCENE - WebShare 2Go App SCENE - 2018 SCENE - 7.x SCENE - 6.x SCENE - 5.x SCENE - 4.x SCENE - LT
SCENE SCENE - 2019 SCENE - 2go App                
Serial FaroArm Serial FaroArm - Silver Serial FaroArm - Gold Serial FaroArm - Bronze              
Structured Light Scanners Cobalt Design - M Cobalt Design - S Cobalt Design - Dual              
Visual Inspect Visual Inspect - App Visual Inspect - CAD Translator                

BuildIT

Construction

FARO® Knowledge Base

Module 3: View Manipulation in BuildIT Construction

BuildITConstruction-bty.png

Objective:

Using BuildIT Construction to navigate and manipulate the view.

3_1_2019.PNG

You’ll learn:

  • A simple workflow for editing the view in BuildIT construction.
  • Opening BuildIT
  • Mouse and Keyboard Shortcuts
  • Saving Views
  • Show and No Show
  • CAD Manipulation

Tutorial Download

If you would like to download the files used in this article, download the accompanying Training Data and extract its contents to a folder on your PC.

Training Data Download
  Download

General Procedure:

  1. Mouse and Keyboard Shortcuts
  2. Saving Views
  3. Show and No Show
  4. CAD Manipulation

Launch BuildIT by double-clicking the BuildIT icon on your desktop.

3_2_icon_2019.PNG

Mouse and Keyboard Shortcuts

  • Open the “Module 3.buildit” file by selecting “File> Open” and navigating to where the file is saved.
  • Selecting objects
    • Left Click objects to select them. Then, select an empty space to deselect. Objects will turn orange when selected, this can be customized in the Settings under Display.
      3_3_2019.PNG
    • To select more than one object, use CTRL and Left Click.
      3_4_2019.PNG
    • Left Click and drag to make a rectangular selection.
      3_5_2019.PNG
  • Menu
    • Right click an object to access the contextual menu.
      3_66_2019.PNG
  • Navigation
    • Zoom All
      • CTRL + 0 ZoomAllIcon.png
    • Predetermined Views
      • ALT + 1, ALT + 2, etc.
        ViewManipulationBuildIT-6.png
    • Zoom
      • The scroll wheel is used to zoom in or out, in the direction of the cursor.
      • Middle mouse is used for smooth zoom in the direction of the cursor.
    • Rotate
      • Left Click to rotate about the location of your cursor.
    • Defaults
      • Defaults can be customized under “File > Settings > Mouse”.
        ViewManipulationBuildIT-7_2019-5.png
         
  • Perspective and orthographic views.
    • The view can be toggled between Perspective and Orthographic. In perspective, the point size is warped based on distance from the viewer. In orthographic, all points and objects are the same size, similar to most CAD platforms.

      3_6_2019.PNG

 

Saving Views

  • Using Save View3_7_2019.PNG
    • Navigate to the intended view, shown below.
    • Click the Save View Icon SaveViewIcon.png or select “View > Save View” from the menu.
    • Enter a name for the view.
    • Select Apply ApplyIcon.png

      3_8_2019.PNG
       
  • Using Set View – Hide the Roof
    • Select “View > Set View”. The Command Panel will appear on the right of the screen.
    • The upper part of the dialog “View:Set” is the camera positioning, which is not normally edited.
    • In this exercise, we'll use "Use clipping box", allowing for hidden elements outside the clipping box.
    • Select the checkbox beside "Use clipping box"
    • Resize the clipping box with the manipulators to hide the roof in the CAD file.

Once the box hides the desired elements, select Apply in the command.
3_9_2019.PNG

3_10_2019.PNG
RESULT:

3_11_2019.PNG

Show and No Show

  • Show and No Show (Shortcut: CTRL+E)
    • This terminology is used to describe the view state of objects. Objects "in Show" will be visible and objects "in No Show" will not be visible until the view state is changed.
    • Select the objects shown.
    • In the ObjectProperties area (lower right), uncheck "Put in Show".
      • This will remove the objects shown from the view.
  • In the Object Properties area (lower right), uncheck “Put in Show”.

3_12_2019.PNG

DisplayObjectMenu.png

ViewManipulationBuildIT-14.png

  • The objects in No Show can be viewed by selecting “View > Toggle Show/No Show”. ShowNoShowIcon.png

CAD Manipulation

  • CAD Data can be manipulated by the user.
    • Change the color of CAD surfaces.
      • Select a surface.
      • In the Object Properties, change the color to a desired color.

        ViewManipulationBuildIT-15.png
    • Change the transparency.
      • Select a surface.
      • In the Object Properties, use the Surface tab.
      • Change the Rendering Mode to “Shaded” and adjust the transparency. Surface normal can also be shown if desired.

        ViewManipulationBuildIT-16.png

Recap:

Congratulations, you have completed the module on view manipulation! By now you should have a grasp of how to:

  • Opening BuildIT
  • Mouse and Keyboard Shortcuts
  • Saving Views
  • Show and No Show
  • CAD Manipulation