Skip to main content
                     
As-Built As-Built - Revit As-Built - AutoCAD VirtuSurv - VirtuSurv 2018 As-Built - Modeler VirtuSurv - VirtuSurv 2019          
BuildIT BuildIT - Projector BuildIT - Construction BuildIT - Metrology              
CAM2 CAM2 - SmartInspect CAM2 - 2018 CAM2 - Measure 10 CAM2 - Measure Q CAM2 - Measure X CAM2 - Measure 3/4 CAM2 - AnthroCAM CAM2 - 2019    
Cobalt 3D Imager 3D Imager - Cobalt                  
Computers Computers - All Computers                  
FARO Aras 360 & CAD Zone FARO CAD Zone - Fire & Insurance FARO CAD Zone - Crime & Crash FARO CAD Zone - CZ Point Cloud FARO CAD Zone - First Look Pro FARO 360 - Reality FARO 360 - HD FARO 360 - Blitz FARO 360 - Genius    
FARO Zone present4D - present4D                  
FARO Zone 2D FARO Zone 2D - 2018 FARO Zone 2D - 2019                
FARO Zone 3D FARO Zone 3D - 2018 FARO Zone 3D - 2019                
FaroArm/ScanArm FaroArm/ScanArm - Quantum S FaroArm/ScanArm - Quantum M FaroArm/ScanArm - Quantum E FaroArm/ScanArm - Edge FaroArm/ScanArm - Fusion FaroArm/ScanArm - Prime FaroArm/ScanArm - Platinum FaroArm/ScanArm - Legacy Quantum FaroArm/ScanArm - Titanium FaroArm/ScanArm - Advantage
FaroArm/ScanArm FaroArm/ScanArm - Digital Template                  
Gage Gage - Bluetooth Gage - Plus Gage - Standard Gage - Power            
Hand Held Scanner 2D Hand Held Scanner - ScanPlan 3D Hand Held Scanner - Freestyle3D 3D Hand Held Scanner - Freestyle3D X 3D Hand Held Scanner - Freestyle3D Objects            
Language Quality HT MT AT NT INT - Internal          
Languages Language - English Language - Japanese Language - German Language - Chinese Language - Spanish Language - Italian Language - Portuguese Language - French    
Laser Projector RayTracer - RayTracer Laser Projector - Tracer M Laser Projector - Tracer SI              
Laser Radar Imaging Laser Radar - VectorRI                  
Laser Scanner 3D Laser Scanner - Focus S 3D Laser Scanner - Focus M 3D Laser Scanner - Focus3D 3D Laser Scanner - Focus3D X 3D Laser Scanner - Focus3D X HDR 3D Laser Scanner - Focus3D S 3D Laser Scanner - Photon      
Laser Tracker Laser Tracker - Vantage Laser Tracker - ION Laser Tracker - Vantage S Laser Tracker - Si Laser Tracker - X Laser Tracker - Xi Laser Tracker - Vantage E Laser Tracker - Vantage S6 Laser Tracker - Vantage E6  
Legacy Software Legacy Software - CAM2 Gage Legacy Software - Gage Software Legacy Software - Insight              
Open Tech Dental Open Technologies Scanner - NeWay Open Technologies Scanner - Click Open Technologies Scanner - Deluxe Open Technologies Scanner - Smart Open Technologies Scanner - Easy Open Technologies Software - 1Click Open Technologies Software - Optical RevEng Dental Open Technologies Software - ScanWay    
Photonics Scan Head - Digi-Cube Scan Head - Xtreme Scan Head - 3D-Contour Scan Head - 3D-Ultralight Scan Head - 3D-XB Controller - LEC Series Controller - Maestro 3000 Nutfield - Nutfield Hardware Nutfield - Nutfield Software Scan Head - Blink Focuser
Photonics WinLase - Pro WinLase - LAN WinLase - 6              
PointSense PointSense - Basic PointSense - Pro PointSense - Building PointSense - Plant PointSense - Heritage PointSense - Revit CAD Plugin - TachyCAD Building CAD Plugin - TachyCAD Archeology CAD Plugin - TachyCAD Interior CAD Plugin - PhoToPlan Basic
PointSense CAD Plugin - PhoToPlan CAD Plugin - PhoToPlan Pro CAD Plugin - PhoToPlan Ultimate CAD Plugin - DisToPlan CAD Plugin - MonuMap CAD Plugin - hylasFM CAD Plugin - VirtuSurv      
RevEng RevEng - RevEng                  
Scan in a Box Scan in a Box - M Scan in a Box - S                
ScanArm ScanArm - Design ScanArm 2.0 ScanArm - Design ScanArm ScanArm - Forensic ScanArm ScanArm - Design ScanArm 2.5C            
SCENE SCENE - Capture and Process SCENE - WebShare Server and 2Go SCENE - WebShare Cloud SCENE - WebShare 2Go App SCENE - 2018 SCENE - 7.x SCENE - 6.x SCENE - 5.x SCENE - 4.x SCENE - LT
SCENE SCENE - 2019 SCENE - 2go App                
Serial FaroArm Serial FaroArm - Silver Serial FaroArm - Gold Serial FaroArm - Bronze              
Structured Light Scanners Cobalt Design - M Cobalt Design - S Cobalt Design - Dual              
Visual Inspect Visual Inspect - App Visual Inspect - CAD Translator                

BuildIT

Construction

FARO® Knowledge Base

Module 7.2: Wall Flatness - Without CAD with BuildIT Construction

BuildITConstruction-bty.png

WallFlat-1.pngObjective:

Use BuildIT Construction to Import a *.E57 file and perform a surface deviation analysis on a cloud surface to evaluate the flatness.

You’ll learn:

  • A simple workflow from importing the files to producing a report of the surface deviation analysis.
  • Opening BuildIT, import a *.E57 file.
  • Creating a surface over the selected cloud
  • Preform surface deviation
  • Produce a Report

Tutorial Download

If you would like to download the file used in this article, download the accompanying Training Data and extract its contents to a folder on your PC.

Training Data Download
  Download

General Procedure:

Import E57 File

  • Launch BuildIT by double-clicking the BuildIT icon on your desktop.
  • Import the scan data by the following method.
    • In the menu bar, click “File > Import > Import E57 Clouds”. ImportE57.png
      ImportDataBuildIT-3_2018.5.png
    • Navigate to and select the file “wall.e57” from the training data and click Open.
    • On the Next screen, click Finish. BuildIT will now begin the import.
      WallPlumb-2_2018.5.png
    • Once the import is completed, many times the point cloud will be outside of the current view, click the Zoom All icon ZoomAllIcon.png to view the entire project.

Create a Surface from the Cloud Points

  • Orient the imported model to the view shown (the ghost image of the vehicle should be visible).
    WallPlumb-3.png
  • Select “Refine > Extract Surface”. ExtractSurfaceIcon.png
  • Create a plane from cloud.
    • In the Tolerance field enter 0.5.
    • Using the Growning selection tool, click on the surface of the wall to select it.
    • Ensure “Create new cloud from identified points” checkbox is selected.
    • Select Apply. ApplyIcon.png
      WallPlumb-4.png

Invert the Surface (if needed)

WallPlumb-6.pngWhen the surface plane has been extracted, there is a possibility the nominal plane may be facing the wrong direction. It is best to check which way the extracted surface is facing. This will help provide the positive and negative direction of the result. The face showing light gray indicates the positive side of the surface and the dark grey side indicates the negative side of the surface.

In the image shown, the dark grey surface plane is facing the top surface of the cloud. Hence the negative value is an in upward direction. Follow the procedure below to reverse the surface orientation.

  • If the surface is in the wrong position, the plane can be flipped by selecting on “Edit > Surface > Reverse Normal”.
  • Select the plane and then Apply. ApplyIcon.png

    FloorFlatness-6.png
  • You should now have a view similar to the image below:
    WallPlumb-7.png

WallPlumb-8.pngPerform Surface Deviation Analysis

  • Create a Surface Deviation plot on the inspected surface.
    • In the menu bar, select “Evaluate > Surface Deviation Analysis”. SurfaceDeviationIcon.png
    • Fill in the command fields as outlined below:
  1. Surfaces - The Surfaces input box is already active (yellow), simply click on the created surface.
  2. Points - The Points input box will automatically populate with the point from the extract surface command, as it was auto-associated.
  3. Maximum search distance - Set the Maximum search distance to 2.0.
    TIP: The Maximum search distance is the distance the software will search from that perfect plane/surface.
  4. Color scale - Pass/Fail will give you a scale for deviations within a tolerance zone.
  5. Analysis mode - Colored patches allow you to see the general pattern in the deviations. Needles are a visual aid for seeing the magnitude of the deviations.
  6. Limit computation - For this procedure, select User-Defined from the drop down and input the required tolerances, +/- 0.25.
  7. When you are done filling in the command, click Apply. ApplyIcon.png

Generate a Report from the Analysis

  • Save a view.
    • Click the Save View Icon SaveViewIcon.png or select “View > Save View” from the menu.
    • Enter a name for the view, and Select Apply. ApplyIcon.png
      FloorFlatness-9.png
       
  • Create a report.
    • In the Manager Tab on the right of the screen, right click on Custom View1 and select Add to report. Also add Surface Deviation Analysis1 to the report.
      FloorFlatness-10.png
    • Click on the Report tab and click on Generate Report. GenerateReportIcon.png
      FloorFlatness-11.png

Recap:

Congratulations, you have completed the module on wall flatness without CAD! By now you should have a grasp of the following:

  • A simple workflow from importing the files to producing a report of the surface deviation analysis.
  • Opening BuildIT, import a *.E57 file.
  • Creating a surface over the selected cloud
  • Preform surface deviation
  • Produce a Report