Skip to main content
                     
As-Built As-Built - Revit As-Built - AutoCAD VirtuSurv - VirtuSurv 2018 As-Built - Modeler VirtuSurv - VirtuSurv 2019          
BuildIT BuildIT - Projector BuildIT - Construction BuildIT - Metrology              
CAM2 CAM2 - SmartInspect CAM2 - 2018 CAM2 - Measure 10 CAM2 - Measure Q CAM2 - Measure X CAM2 - Measure 3/4 CAM2 - AnthroCAM CAM2 - 2019 CAM2 - 2020  
Cobalt 3D Imager 3D Imager - Cobalt                  
Cobalt Design Cobalt Design - M Cobalt Design - S Cobalt Design - Dual              
Computers Computers - All Computers                  
FARO Aras 360 & CAD Zone FARO CAD Zone - Fire & Insurance FARO CAD Zone - Crime & Crash FARO CAD Zone - CZ Point Cloud FARO CAD Zone - First Look Pro FARO 360 - Reality FARO 360 - HD FARO 360 - Blitz FARO 360 - Genius    
FARO Zone present4D - present4D                  
FARO Zone 2D FARO Zone 2D - 2018 FARO Zone 2D - 2019 FARO Zone 2D - 2020 FARO Zone 2D - 2021            
FARO Zone 3D FARO Zone 3D - 2018 FARO Zone 3D - 2019 FARO Zone 3D - 2020 FARO Zone 3D - 2021            
FARO Zone 3D Advanced FARO Zone 3D Advanced - 2018 FARO Zone 3D Advanced - 2019 FARO Zone 3D Advanced - 2020 FARO Zone 3D Advanced - 2021            
FaroArm/ScanArm FaroArm/ScanArm - Quantum S FaroArm/ScanArm - Quantum M FaroArm/ScanArm - Quantum E FaroArm/ScanArm - Edge FaroArm/ScanArm - Fusion FaroArm/ScanArm - Prime FaroArm/ScanArm - Platinum FaroArm/ScanArm - Legacy Quantum FaroArm/ScanArm - Titanium FaroArm/ScanArm - Advantage
FaroArm/ScanArm FaroArm/ScanArm - Digital Template FaroArm/ScanArm - Gage                
Hand Held Scanner 2D Hand Held Scanner - ScanPlan 3D Hand Held Scanner - Freestyle3D 3D Hand Held Scanner - Freestyle3D X 3D Hand Held Scanner - Freestyle3D Objects 3D Hand Held Scanner - Freestyle 2          
Language Quality HT MT AT NT INT - Internal Sales - Internal Resources Sales - Order and Quote Sales - Product Info Sales - Sales Readiness Sales - Training
Language Quality CS - Procedures and Product Sales - Product Launch Sales - Promotions              
Languages Language - English Language - Japanese Language - German Language - Chinese Language - Spanish Language - Italian Language - Portuguese Language - French    
Laser Projector RayTracer - RayTracer Laser Projector - Tracer M Laser Projector - Tracer SI              
Laser Radar Imaging Laser Radar - VectorRI                  
Laser Scanner 3D Laser Scanner - Focus S 3D Laser Scanner - Focus M 3D Laser Scanner - Focus3D 3D Laser Scanner - Focus3D X 3D Laser Scanner - Focus3D X HDR 3D Laser Scanner - Focus3D S 3D Laser Scanner - Photon 3D Laser Scanner - Focus S Plus 3D Laser Scanner - Swift  
Laser Tracker Laser Tracker - Vantage Laser Tracker - ION Laser Tracker - Vantage S Laser Tracker - Si Laser Tracker - X Laser Tracker - Xi Laser Tracker - Vantage E Laser Tracker - Vantage S6 Laser Tracker - Vantage E6  
Legacy Gage Legacy Gage - Bluetooth Legacy Gage - Plus Legacy Gage - Standard Legacy Gage - Power            
Legacy Software Legacy Software - CAM2 Gage Legacy Software - Gage Software Legacy Software - Insight              
PointSense PointSense - Basic PointSense - Pro PointSense - Building PointSense - Plant PointSense - Heritage PointSense - Revit CAD Plugin - TachyCAD Building CAD Plugin - TachyCAD Archeology CAD Plugin - TachyCAD Interior CAD Plugin - PhoToPlan Basic
PointSense CAD Plugin - PhoToPlan CAD Plugin - PhoToPlan Pro CAD Plugin - PhoToPlan Ultimate CAD Plugin - DisToPlan CAD Plugin - MonuMap CAD Plugin - hylasFM CAD Plugin - VirtuSurv      
RevEng RevEng - RevEng                  
ScanArm ScanArm - Design ScanArm 2.0 ScanArm - Design ScanArm ScanArm - Forensic ScanArm ScanArm - Design ScanArm 2.5C            
SCENE SCENE - Capture and Process SCENE - WebShare Server and 2Go SCENE - WebShare 2Go App SCENE - 2018 SCENE - 7.x SCENE - 6.x SCENE - 5.x SCENE - 4.x SCENE - LT SCENE - 2019
SCENE SCENE - 2go App SCENE - 2020                
Serial FaroArm Serial FaroArm - Silver Serial FaroArm - Gold Serial FaroArm - Bronze              
Visual Inspect Visual Inspect - App Visual Inspect - CAD Translator                
WebShare WebShare - Enterprise WebShare - WebShare Cloud                
FARO® Knowledge Base

Surface Flatness Analysis with BuildIT Construction

Objective

Use BuildIT Construction to compare scan data to a surface to create a heatmap, topography, and calculate cut or fill volume.

You’ll Learn

  • Importing scan data.
  • Creating reference surfaces.
  • Performing the Surface Flatness command.
  • Producing a report.

Tutorial Data

Data Link: Downloads

Import scan data

  • Use File > Import > Import CPE Clouds to import the example scan.Buildit_Import CPE CLouds.png
  • Note: CPE files can be exported from FARO SCENE or Webshare. Other scan data types can also be used for this workflow.

    Buildit_Import CPE CLouds Device.png

Create reference surface

  • Restore a top view of the point cloud by selecting the top view on the toolbar. Or by selecting Alt + 8 on a keyboard.
    Buildit_Top surface.png
  • Use Refine > Extract Surface to extract a best fit and level plane.
    • Ensure that the surface type is selected as “Plane” and use the rectangular selection to select the area of the floor to analyze.
    • Once the rectangular selector is enabled for the “Points” section, you can either double left click on the screen to start the selection or use CTRL + Left Click to start the selection.
      Buildit_extract surface.png
      Buildit_extract surface plane 1.png
      Buildit_extract surface plane view.png
      Buildit_Constrain normalaxis.png
  • For “Constraint”, select “Constrain normal/axis” to make the plane perfectly level. 
  • For “Constaint normal”, select Z.
  • For tolerance, select 1” or 25mm. Note that in version 2020.5 and after, you can also enter “1 in” or “25 mm” to automatically convert to current units. This also accepts imperial unit imports such as “1 ft 1 1/2 in” and will convert them to decimals.
  • Select Apply.
    Buildit_tolerance.png
    Buildit_plane surface.png
     

Perform the Surface Flatness command

  • Save your file to a known location by using File > Save.Buildit_surface flatness analysis.png
  • Start the command by selecting Evaluate > Surface Flatness Analysis. 
  • Select the following inputs:
    • Surface - Plane 1
    • Point Clouds - Floor
    • Analysis Options
      • Create Heatmap - Checked
        • This allows us to colorize the point cloud, identifying areas that are above or below our reference plane.
      • Create Topography - Checked
        • This allows us to create curves representing various levels above or below our reference plane. This also creates a dxf automatically, saved in the same location as your BuildIT file.
      • Calculate Cut and Fill Volume - Checked
        • This allows us to calculate the volume above or below our reference plane, for the purpose of cutting down or building up the floor to a desired level.
    • Tolerances
      • Deviation Tolerance - 0.25 inch.
        • This represents the area above or below our reference plane which we consider “good” or green and outside of this value is considered “bad”.
      • Heatmap Type - Pass/Fail RGB
        • Pass/Fail RGB will make areas within our tolerance green, below blue, and above red.
        • Rainbow will create an even colorization within our search distance.
        • USIBD Lower uses the lower range for the USIBD LOA guide.
        • USIBD Upper uses the upper range for the USIBD LOA guide.
    • Filtering
      • Grid Size - 6 inch
        • When creating topography or cut/fill volumes, we break the point cloud down into a grid. This value represents the size of that grid, with smaller values taking longer to process with finer detail.
      • Height evaluation - Cell Average
        • Cell average will create an average reference point from all the points in a cell.
        • Low/High Point will create a point from the highest or lowest deviation from reference to represent the cell.
        • Center Point will create a point from the point closest to the middle of the cell.
      • Max search distance - 12 inch
        • This represents the maximum distance to search above or below our reference plane.
      • Iso-Height curve spacing - 0.25 inch
        • This value represents the detail level of the topography. The lower the number, the finer the difference in topographic height deviation.
      • Min. island size - 1 inch
        • Minimum island size controls the minimum size of contours. If you run the command and have a high number of small contours, increase the value of minimum island size.
      • Detect Walls - True
        • This setting detects walls in the scan data and ignores them instead of creating curves to represent this cell.
      • Clean-Up Debris - True
      • Clean-Up Debris Height - 6 inch
        • This controls the maximum point height per cell. This is useful to include then there is extra data in the scan other than the floor.
          Buildit_command analysis.png
  • Select Apply and let the analysis run. There will be several steps performed and analysis time may vary based on the size of the point cloud.
    Buildit_Point 1.png
    Buildit_Point 2.png
    Buildit_Point 3.png

Produce a report

  • A report is automatically generated for the cut and fill volume analysis. You can run it directly by selecting Report > Generate Report.
    Buildit_Generate Report.png
  • For other views as shown in the previous step, you can select items in the manager to turn on or off (CTRL + E when selected on the item) or activate the other analysis. As an example, to create the view shown:
    • Under your Measurements, ensure only the point cloud with “_Analysis” is at the end. In our example, it should be called “Plane1_Analysis”.
    • Ensure the analysis ending in “Deviation Analysis” is active by double clicking or right click > activate. In our example, this should be called “Plane1 Deviation Analysis”.
    • Use View > Save View to create a view for the report.
      Buildit_Save view.png
  • Add this view to the report by right clicking on it in the manager and selecting “Add to Report”.
    Buildit_Add to report.png
    Buildit_Point 2.png

Recap

Congratulations on completing the module. You should now be able to:

  • Import scan data.
  • Create a reference surfaces.
  • Perform the Surface Flatness command.
  • Produce a report.
     
  • Was this article helpful?