Skip to main content
                     
As-Built As‑Built - Revit As‑Built - AutoCAD VirtuSurv - VirtuSurv 2018 As‑Built - Modeler            
BuildIT BuildIT - Metrology BuildIT - Projector BuildIT - Construction              
CAM2 CAM2 - SmartInspect CAM2 - AnthroCAM CAM2 - 2018 CAM2 - Measure 10 CAM2 - Measure Q CAM2 - Measure X CAM2 - Measure 3/4      
Cobalt 3D Imager 3D Imager - Cobalt                  
Computers Computers - All Computers                  
FARO Aras 360 & CAD Zone FARO 360 - Reality FARO 360 - HD FARO 360 - Blitz FARO 360 - Genius FARO CAD Zone - Fire & Insurance FARO CAD Zone - Crime & Crash FARO CAD Zone - CZ Point Cloud FARO CAD Zone - First Look Pro    
FARO Zone FARO Zone - 2D FARO Zone - 3D                
FaroArm/ScanArm FaroArm/ScanArm - Edge ScanArm - Design ScanArm ScanArm - Forensic ScanArm ScanArm - Design ScanArm 2.5C ScanArm - Design ScanArm 2.0 FaroArm/ScanArm - Quantum S FaroArm/ScanArm - Quantum M FaroArm/ScanArm - Quantum E FaroArm/ScanArm - Fusion FaroArm/ScanArm - Prime
FaroArm/ScanArm FaroArm/ScanArm - Platinum FaroArm/ScanArm - Legacy Quantum FaroArm/ScanArm - Titanium FaroArm/ScanArm - Advantage FaroArm/ScanArm - Digital Template          
Gage Gage - Bluetooth Gage - Plus Gage - Standard Gage - Power            
Hand Held Scanner 3D Hand Held Scanner - Freestyle3D 3D Hand Held Scanner - Freestyle3D X 3D Hand Held Scanner - Freestyle3D Objects 2D Hand Held Scanner - ScanPlan            
Language Quality HT MT AT NT INT - Internal          
Languages Language - English Language - Japanese Language - German Language - Chinese Language - Spanish Language - Italian Language - French Language - Portuguese    
Laser Projector RayTracer - RayTracer Laser Projector - Tracer M Laser Projector - Tracer SI              
Laser Radar Imaging Laser Radar - VectorRI                  
Laser Scanner 3D Laser Scanner - Focus S 3D Laser Scanner - Focus M 3D Laser Scanner - Focus3D 3D Laser Scanner - Focus3D X 3D Laser Scanner - Focus3D X HDR 3D Laser Scanner - Focus3D S 3D Laser Scanner - Photon      
Laser Tracker Laser Tracker - Si Laser Tracker - ION Laser Tracker - Vantage S6 Laser Tracker - Vantage Laser Tracker - X Laser Tracker - Xi Laser Tracker - Vantage S Laser Tracker - Vantage E Laser Tracker - Vantage E6  
Legacy Software Legacy Software - CAM2 Gage Legacy Software - Gage Software Legacy Software - Insight              
Photonics Scan Head - Digi-Cube Scan Head - Xtreme Scan Head - 3D-Contour Scan Head - 3D-Ultralight Scan Head - 3D-XB Controller - Maestro 3000 Controller - LEC Series      
PointSense PointSense - Basic PointSense - Pro PointSense - Building PointSense - Plant PointSense - Heritage PointSense - Revit CAD Plugin - TachyCAD Building CAD Plugin - TachyCAD Archeology CAD Plugin - TachyCAD Interior CAD Plugin - PhoToPlan Basic
PointSense CAD Plugin - PhoToPlan CAD Plugin - PhoToPlan Pro CAD Plugin - DisToPlan CAD Plugin - MonuMap CAD Plugin - hylasFM CAD Plugin - VirtuSurv CAD Plugin - PhoToPlan Ultimate      
RevEng RevEng - RevEng                  
SCENE SCENE - Capture and Process SCENE - WebShare Server and 2Go SCENE - WebShare Cloud SCENE - WebShare 2Go App SCENE - 2018 SCENE - 4.x SCENE - 5.x SCENE - 6.x SCENE - 7.x SCENE - LT
Serial FaroArm Serial FaroArm - Bronze Serial FaroArm - Gold Serial FaroArm - Silver              
Visual Inspect Visual Inspect - App Visual Inspect - CAD Translator                

SCENE

2018

6.x

7.x

English

FARO® Knowledge Base

Registering with Survey Data in SCENE

kA270000000Cam0CAC_en_US_1_2.png

 

Overview

External reference objects, such as survey data, can be used to align scan projects with real-world coordinates. This data can be imported through both SCENE interfaces. 

Survey Data Format

SCENE will recognize COR, CSV, and TXT survey data formats. Each row of the survey data file should contain a single reference point with the following specifications: name, x coordinate, y coordinate, and z coordinate. 

Note: When importing survey data, SCENE uses a right-handed coordinate system.


Example CSV file


Example TXT file

If you are using a TXT file, data must be separated by the same type of separator, which can be a blank space, a colon, a semicolon, or a tab.

Verify Measurement Units

The measurement units of the import setting must match the units of the data being imported. This setting can be checked in both interfaces. 

Workflow Interface

  1. Click the Settings  icon  on the top-right of the window.
  2. Click Import on the left side of the window.
  3. Choose the measurement unit of the survey data to be imported.

Classic Interface

  1. Click Tools > Options in the main menu.
  2. In the Options window, click the Units tab and select the correct measurement unit in the Import menu. 

Importing Survey Data

You can import survey data by dragging the file from your desktop onto the white area of the Structure tree. You can also import survey data through both SCENE interfaces.

Workflow Interface

  1. Click Import Surveyed Points on the Registration ribbon.
  2. Navigate to the folder containing the survey point data. Click the file to be imported and click Open. Note: You may have to adjust the file-type filter to make sure the survey data file is visible.

    Note: TXT files can not be imported with this method. They have to be dragged and dropped from the desktop to the Structure tree.
  3. In the dialog box, choose which structure level should contain the imported points. 

    Note: Importing data on the workspace level will make that data available to the entire project. Importing data on the cluster level will restrict data to a specific cluster.
  4. A References folder will appear in the structure view.

Classic Interface

  1. Click File > Import in the main menu.
  2. Navigate to the folder containing the survey point data. Click the file to be imported and click Open. Note: You may have to adjust the file-type filter to make sure the survey data file is visible.

    Note: TXT files can not be imported with this method. They have to be dragged and dropped from the desktop to the Structure tree.
  3. In the dialog box, choose which structure level should contain the imported points. 

    Note: Importing data on the workspace level will make that data available to the entire project. Importing data on the cluster level will restrict data to a specific cluster.
  4. A References folder will appear in the structure view.

Survey Data and Project Structure

When using survey data to align or transform your project, you can protect the registration of the project's individual scans by moving them into a cluster.

To create a cluster, follow these steps.

  1. Right-click the project folder and click New > Cluster.
  2. Enter a name for the new cluster in the Name field of the cluster properties box and click OK.
  3. The new cluster will appear in the top level of the Structure tree.
  4. Click the  icon next to the original scan cluster and drag it into the new cluster. 

Note: Clusters can be created on any level of the project structure tree and moved as needed. 

Registering Scans with Survey Data

Once survey data is imported, SCENE will prioritize reference points in the registration process. To successfully register scans, you will need correspondences between at least three scan targets and the imported reference points. You can register and verify these correspondences during the registration process using the steps below.

Workflow Interface

  1. In the Registration ribbon, click the Registration icon  next to the scan cluster to be registered and click Start Automatic Registration.
  2. In the Select Method pull-down menu, click Target Based.
    • Verify Targets - Check this box to manually inspect survey point correspondences before registration.
    • Find correspondences for scan positions - Check this box if survey data corresponds with scanner positions.
    • Force correspondences by target names - Check this box to force correspondences between scans by giving objects the same name.
    • Use checkerboard normals - Disable this setting if checkerboard targets are placed at angles to the scanner.
  3. Click the green Verify Targets or Register and Verify button on the top-right.

Verifying Targets

The Verify Targets window contains verification controls on the left and a loaded scan on the right.

  1. To verify survey data, click a scan name on the scan list.
  2. You should see the survey point displayed on the corresponding target. 
  3. To check the point, right-click it and click Properties.
  4. You should see the corresponding reference point in the window label.
  5. When you are done verifying targets, click Register and Verify on the top-right.

Classic Interface

  1. In the Structure tree, right-click a scan containing a reference point and click View > Planar View.
  2. You should see the survey point placed on the corresponding target. 
  3. To check the point, right-click it and click Properties.
  4. You should see the corresponding reference point in the window label.
  5. When you are done verifying targets, right-click the top-level Scan Manager and click Update Scans. Note: You may be prompted to unlock the scan manager.
  6. Verify the results in the Scan Manager window.
  7. Click OK.

See Also

Keywords: registration, scans, external reference features, survey points